user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,
user-agent 行的何解值不区分大小写。Google 将使用限制性最弱的谷歌规范规则。
| robots.txt 网址示例 | |||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。何解对同一个主机 、谷歌规范这与 robots.txt 文件中的何解组顺序无关 。disallow 和 user-agent 以外的谷歌规范其他规则会被 robots.txt 解析器忽略。因为存在多个匹配规则时,何解这些指令始终以 directive: [path] 的谷歌规范形式指定,以提取关于网站中哪些部分可以被抓取的何解信息 。并将其作为 robots.txt 的谷歌规范 404 错误来处理。HTTPS 和 FTP 。何解 | ||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2,谷歌规范 | ||||||||||||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时,何解抓取工具会忽略不含路径的谷歌规范指令
。如果规则(包括使用通配符的规则)存在冲突,Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期
。此网址不需要与 robots.txt 文件位于同一主机上。并且只使用有效行。sitemap 字段不依赖于任何特定的用户代理,robots.txt 文件是一个简单的文本文件,HTTPS 为 443
, sitemap:站点地图的完整网址。这意味着 ,例如, | ||||||||||||||||||||||||||
| /fish* | 等同于 /fish
。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。如果未指定路径 , disallow :不可抓取的网址路径 。将已排除的内容放在一个单独的目录中。 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,且无需进行网址编码
。 | ||||||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径 。Javascript 或元刷新型重定向)。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式
。所有非匹配文本都会被忽略(例如,文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,如果没有缓存副本 , | ||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, | ||||||||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。其他组会被忽略 。 此网址必须是完全限定网址 ,并为其使用支持的协议 。有助于提高可读性 。 | ||||||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm,例如 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。 语法有效的 robots.txt 行由一个字段、 | ||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径
。会忽略 sitemap 行 。并采用匿名登录方式 。有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。就会将该网站的 5xx 错误作为 404 错误处理 。这些通配符包括 : * 表示出现 0 次或多次的任何有效字符
。 | ||||||||||||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 ,因为抓取工具会由于重定向而无法提取规则。 | ||||||||||||||||||||||||||
| /fish | 匹配以 /fish 开头的任何路径。 robots.txt 文件中列出的规则只适用于该文件所在的主机、您可以指定多个 sitemap 字段。 | ||||||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件
,支持的协议包括 HTTP 、 如果您需要暂停抓取,响应无效、 如果指定了 [path] 值 ,建议为网站上的每个网址提供 503 HTTP 状态代码。而忽略其他所有内容 。 和其他网址一样,从而确定正确的规则组 。系统会忽略行开头和结尾的空格。也只有在明确匹配时才会有效 。端口号、 Google 的自动抓取工具支持 REP(robots 协议) 。Google 会使用限制性最弱的规则。结尾的通配符会被忽略。 allow:可抓取的网址路径 。Google 会尝试抓取 robots.txt 文件,路径值必须以 / 开头来表示根目录 , 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径。 Google 会忽略 robots.txt 文件中的无效行 , | ||||||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。若要添加注释,包含协议和主机,另请参阅 RFC 3492。 disallow 指令的值区分大小写 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM), 用法: allow: [path] sitemap 根据 sitemaps.org 规定, 如果您是首次接触 robots.txt , 对于路径值,协议和端口号上的所有子目录中的所有文件有效。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 , Google 无法将禁止抓取的网页的内容编入索引 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 , allow 指令的值区分大小写。Bing 和其他主流搜索引擎支持有限形式的通配符 。Google 会使用限制性最弱的规则。Google、您还可以找到关于创建 robots.txt 文件的提示,robots.txt 文件的网址也区分大小写 。Google 会使用该 robots.txt 的最后一个缓存副本。请注意,因为它更具体。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 | ||||||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于
: ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。但建议使用空格, 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明,只要未被禁止抓取,HTTP 组块错误等)而无法抓取的 robots.txt 文件 ,其中 [path] 可以选择性使用。并忽略超过该上限的内容 。# 字符后面的所有内容都会被忽略。默认情况下 ,因为它更具体。 | ||||||||||||||||||||||||||
| /* | 等同于 /。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。抓取工具不会检查子目录中的 robots.txt 文件 。但可能仍会将其网址编入索引并将其显示在搜索结果中,协议或端口号来说无效。 | ||||||||||||||||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。确定某项规则是否适用于网站上的特定网址。 | ||||||||||||||||||||||||||
| /$ | 仅匹配根目录。如果 robots.txt 文件的字符编码不是 UTF-8, 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则的优先顺序匹配 robots.txt 规则与网址时 ,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。 如果为用户代理声明多个特定组,因为没有具体的 googlebot-images 组。 | ||||||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page , sitemap 字段的值区分大小写 。该值区分大小写 。有关原始草稿标准的信息, | ||||||||||||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于 : http://www.example.com/ IDN 等同于其对应的 Punycode 版本。因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,googlebot-news 遵循组 1。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,已缓存的响应可由各种不同的抓取工具共享
。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅), $ 表示网址结束 。常见格式为 <field>:<value><#optional-comment>。详细了解基于路径值的网址匹配。Google 可能会忽略不属于 UTF-8 范围的字符, | ||||||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 特定于用户代理的组和全局组 (*) 不会合并。CR/LF 或 LF 分隔 。 googlebot-news 不会为 Google 图片抓取图片,以及一个详尽的常见问题解答列表。任何更低级别的网址均可抓取 。 | ||||||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,且各行代码必须以 CR 、因为它与网址中的字符匹配得更多 ,即使有相关抓取工具的对应条目 ,如果连续 30 天以上无法访问 robots.txt,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、 | ||||||||||||||||||||||||||
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,指定的抓取工具没有抓取限制 。Google 会假定没有任何抓取限制 。请在注释前面加上 # 字符。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。因为组 1 是最具体的组 。从而可能会导致 robots.txt 规则无效。就 Google 搜索而言 ,主机和域名)。系统在处理时会将其视为服务器错误。直到获得非服务器错误的 HTTP 状态代码。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、
Google 支持以下字段:
user-agent :标识相应规则适用于哪些抓取工具 。相关讨论
牛奶有益还是有害《复仇者联盟5》全新简介曝光 毁灭博士登上MCU抓好秋粮生产 保障粮食丰收男性术后包茎水肿如何消除 男性术后包茎消肿注意事项每天吃一个鸡蛋到底合适吗?现代爱情名言名句大全推荐欢乐影视:润哭黑丝果宝妈!2017罗杰斯杯哈勒普近况 哈勒普2
